RESOLVER(5) BSD File Formats Manual RESOLVER(5)
resolver − resolver configuration file
The resolver is a set of routines in the C library (resolve(3)) that provide access to the Internet Domain Name System. The resolver configuration file contains information that is read by the resolver routines the first time they are invoked by a process. The file is designed to be human readable and contains a list of keywords with values that provide various types of resolver information.
On a normally configured system, this file should not be necessary. The only name server to be queried will be on the local machine, the domain name is determined from the host name, and the domain search path is constructed from the domain name.
The different configuration directives are:
Internet address (in dot notation) of a name server that the resolver should query. Up to MAXNS (see <resolv.h>) name servers may be listed, one per keyword. If there are multiple servers, the resolver library queries them in the order listed. If no nameserver entries are present, the default is to use the name server on the local machine. (The algorithm used is to try a name server, and if the query times out, try the next, until out of name servers, then repeat trying all the name servers until a maximum number of retries are made).
The search list is currently limited to six domains with a total of 256 characters.
sortlist 220.127.116.11/255.255.240.0 18.104.22.168
Allows certain internal resolver variables to be modified. The syntax is options option ... where option is one of the following:
debug’ sets RES_DEBUG in _res.options.
rotate’ sets RES_ROTATE in _res.options, which causes round robin selection of nameservers from among those listed. This has the effect of spreading the query load among all listed servers, rather than having all clients try the first listed server first every time.
inet6’ sets RES_USE_INET6 in _res.options. This has the effect of trying a AAAA query before an A query inside the gethostbyname function, and of mapping IPv4 responses in IPv6 ‘‘tunnelled form’’ if no AAAA records are found but an A record set exists.
The domain and search keywords are mutually exclusive. If more than one instance of these keywords is present, the last instance wins.
The search keyword of a system’s resolv.conf file can be overridden on a per-process basis by setting the environment variable ‘‘LOCALDOMAIN’’ to a space-separated list of search domains.
The options keyword of a system’s resolv.conf file can be amended on a per-process basis by setting the environment variable ‘‘RES_OPTIONS to a space-separated list of’’ resolver options as explained above under options.
The keyword and value must appear on a single line, and the keyword (e.g., nameserver) must start the line. The value follows the keyword, separated by white space.
gethostbyname(3), hostname(7), named(8), resolver(3), resolver(5). ‘‘Name Server Operations Guide for BIND’’
4th Berkeley Distribution November 11, 1993 4th Berkeley Distribution